Page 1 of 1

Cannot boot hirensbootcd

Posted: 11 Jun 2015, 11:40
by colonel
Hi, I've encountered problems booting hirensbootcd.ima (DOS version of Hiren's boot CD).
I followed instructions at
but after choosing menu item "Hiren's BootCD 15.1 DOS" erpxe just returns to menu without any error message after trying to load image.
I switched off menu and tried to load image from syslinux shell typing:
/boot/isolinux/memdisk RAW initrd=er/plugins/hirensbootcd/hirensbootcd.ima
and it showed:
"booting kernel failed: invalid argument"
after digging internet for this error message I've found that it is a bug in pre-6.03 versions of syslinux (and in 6.02 on which erpxe is based)
So I downloaded 6.03 and changed pxelinux.0, memdisk and all other modules in erpxe path.
But nothing changed.
I went further and tried version 4.07 of syslinux and it worked OK!
But such old version is incompatible with erpxe menu system and I managed to load kernel only from command line.
So what are the options to load hiren's boot cd? Maybe there are any workarounds?

Re: Cannot boot hirensbootcd

Posted: 11 Jun 2015, 13:14
by RaveMaker
I'm not sure about version 4.07 with ERPXE but it used to run with version 4.
run the following command on the server:

Code: Select all

tail -f /var/log/messages
now try booting into ERPXE and see if there is a 'sending NAK (1, File not found)' and which file is missing.

Re: Cannot boot hirensbootcd

Posted: 11 Jun 2015, 14:06
by colonel
My server is running Windows Server 2003 with its own TFTP service, I don't know are there any logs.

Re: Cannot boot hirensbootcd

Posted: 11 Jun 2015, 14:57
by colonel
Thanks to syslinux irc chat the problem is solved.
I changed order of parameters
in file er/plugins/hirensbootcd/
INITRD er/plugins/hirensbootcd/hirensbootcd.ima
APPEND initrd=er/plugins/hirensbootcd/hirensbootcd.ima raw
(removed INITRD line and put ima path to the APPEND itself and turned 'raw' lowercase)