Page 2 of 2

Re: Help with ERPXE install on Raspberry Pi

Posted: 22 Nov 2013, 19:19
by burton666
I followed your guide to the letter but It seems like I get similar errors again. Is this normal?:

sudo apt-get install tftpd-hpa
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 54 not upgraded.
Need to get 46.1 kB of archives.
After this operation, 142 kB of additional disk space will be used.
Get:1 wheezy/main tftpd-hpa armhf 5.2-4 [46.1 kB]
Fetched 46.1 kB in 0s (72.3 kB/s)
Preconfiguring packages ...
Selecting previously unselected package tftpd-hpa.
(Reading database ... 65274 files and directories currently installed.)
Unpacking tftpd-hpa (from .../tftpd-hpa_5.2-4_armhf.deb) ...
Processing triggers for man-db ...
Setting up tftpd-hpa (5.2-4) ...
[....] Starting HPA's tftpd: in.tftpdinvoke-rc.d: initscript tftpd-hpa, action "start" failed.
dpkg: error processing tftpd-hpa (--configure):
subprocess installed post-installation script returned error exit status 71
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo update-rc.d tftpd-hpa defaults
update-rc.d: using dependency based boot sequencing
update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match tftpd-hpa Default-Stop values (1)

Re: Help with ERPXE install on Raspberry Pi

Posted: 22 Nov 2013, 20:02
by burton666
I tried adding the "--ipv4" to the options again and it seems to work. the next update command still gives me the same error.

When I get to this command "useradd –no-create-home -s /dev/null erpxe" I also get a error. Tried changing it to "useradd -M -s /dev/null erpxe" and I think I works.

Then I get this:

cat /tftpboot/bin/setup/smb.conf > /etc/samba/smb.conf
cat: /tftpboot/bin/setup/smb.conf: No such file or directory

Re: Help with ERPXE install on Raspberry Pi

Posted: 23 Nov 2013, 02:59
by commguy
Ok two problems, first no that's not normal. dpkg should not return an error installing tftpd-hpa. However, the runlevel warning is just that, a warning and can be ignored. You can manually edit the init file to reflect the proper run level args to get rid of that error but I don't have the brain power to walk you thru that tonight. All in all it will work fine the way it is.

As for the useradd error, the -M should be unnessessary but if it works I won't argue. I ran thru all of the steps I put in the walkthru as I was writing it to make sure I had it all right. Did you start with a fresh RPi install? How did you install it?

The file is an easy one each of the files you will be using cat or cp with are called erpxe-(file).extension

so for the smb file you would use

Code: Select all

cat /tftpboot/bin/setup/erpxe-smb.conf > /etc/samba/smb.conf
Appologies, I missed that one, I'll fix it.

I'll run thru the install again this weekend to verify all the steps.

Re: Help with ERPXE install on Raspberry Pi

Posted: 24 Nov 2013, 02:26
by commguy
I take that back, I'm in the middle of a redesign on the case and adding some new hardware features. Since I have to dismantle my system to swap SD cards to do this I'm going to hold off until I'm ready to reconfigure the hardware. Please let me know if you encounter any more problems so I can try to address it.

I did try to cover all the bases and I know this process works as I've repeated it several times. However with changes in some of the packages it does have a few variations each time that will need to be accounted for and updated on a regular basis.

Re: Help with ERPXE install on Raspberry Pi

Posted: 11 Dec 2013, 07:15
by commguy
well I got my sdcard extension cable and it doesn't work. The cable itself passes the read/write tests but for some reason, I'm guessing having to do with the low power of the pi, it will not work with the pi.

At any rate I went ahead and ran thru the install again and updated my instructions. I used noobs this time and after modifying the instructions a little everything seemed to install ok. There were errors but once I completed the last step and rebooted everything worked like a charm.

noobs is actually fairly quick and makes the process a little less painful. Try the updated instructions and see if that helps you.

Re: Help with ERPXE install on Raspberry Pi

Posted: 11 Dec 2013, 18:17
by commguy
a couple more things I found after testing my new install.

rpcbind is required for nfs to work. samba-common-bin is required to set passwords and add users to samba shares. I updated the instructions to reflect that.

Re: Help with ERPXE install on Raspberry Pi

Posted: 20 Dec 2013, 19:04
by ET-CS
I've added this great tut to the official ERPXE wiki:

Re: Help with ERPXE install on Raspberry Pi

Posted: 04 Jan 2014, 00:48
by commguy
Thanks! felt great to see my work show up on the wiki.

That said I have a couple of corrections. I didn't realize this but the rpcbind service doesn't automatically start on the rpi.

Code: Select all

update-rc.d rpcbind enable

must be used to start this.

The first code segment below ERPXE header has Install a TFTP Service as part of the code instead of a heading for the next section.

Code: Select all

service tftpd-hpa restart
should be issued at the prompt after editing the conf file. It looks like it's part of the code on the wiki.

Config TFTP service - this is just in a weird place. I should have caught that before I submitted it. Sorry.

-update-rc.d nfs-kernel-server defaults there is a dash at the beginning of this command that shouldn't be.

dhcpd.conf needs to be modified to reflect the network setup used or some services will not work.

Thanks in advance and I appreciate wiki entry.

Re: Help with ERPXE install on Raspberry Pi

Posted: 06 Jan 2014, 09:11
by ET-CS