TFTP Download Failed

Post Reply
Posts: 2
Joined: 26 Jul 2013, 12:24

TFTP Download Failed

Post by nixer » 26 Jul 2013, 13:15

I just found this ERPXE project yesterday and spent the day trying to get it to work. I have not succeeded, yet. Whenever I try to load the hirensminixp.iso I get a message "TFTP Download Failed". Nothing else shows on the screen.

I have a Debian Stable system running the atftpd program. The tftpd-hpa would not install without errors so I am trying to use a different tftp server. This atftp program likes for the default location to be at /srv/tftp and erpxe suggests it at /tftpboot. No problem so far as I symlinked the root of /tftpboot to /srv/tftp. It does load the program and I can navigate the erpxe menu. I might add that the atftp server works fine with other pxe boots, just not this erpxe.

I went through the installation and configuration of erpxe and all went fine except for the command "smbpasswd -a erpxe" which threw out an error. I don't think this is critical, for now, so I will move on. Everything seems fine except that I am unsure where to put this information: "-m /tftpboot/er.remap -vvvvv -s". I added it to the /etc/default/atftp.conf file as -
OPTIONS="--tftpd-timeout 300 --retry-timeout 5 --mcast-port 1758 --mcast-addr --mcast-ttl 1 --maxthread 100 --verbose=5 -m /tftpboot/er.remap"
I had to drop the -s flag as the service would not start with it added. This does not seem to help any. I also added it to the /etc/init.d script on the "Options" line as "-m /tftpboot/er.remap -vvvvv -s". This does not help any either. I am unsure about this. Is there a proper way that you suggest do add it?

My creation of the hirensminixp.iso file was attempted three times with the hex editing done at least 4 times. I am pretty sure that I have got this right, but then, maybe not. I checked my /var/log/daemon file and I get this message:
Jul 25 22:56:29 server atftpd[27551]: Serving er/plugins/ to
Jul 25 22:56:32 server atftpd[27551]: Serving er/plugins/hirensminixp/startrom.0 to
Jul 25 22:56:32 server atftpd[27551]: Serving WIN\H to
The error log stops here.

I don't know which direction to take from here. I may have picked a more advanced plugin to use as my first try with erpxe, but it is one that I would use often so I tried it. Any suggestions?

Update: I just tried a easier plugin, the partedmagic plugin. It too will not download, but i get no error message in the log. The last line in the log file says:
Jul 26 10:12:17 server atftpd[3659]: Serving er/plugins/partedmagic/i386/bzimage to
Jul 26 10:12:24 server atftpd[3659]: Serving er/menu/skin/menu.png to
and then the log stops. I can browse the erpxe menu including the PMagic menu entry, and then once selected, nothing happens.

I am missing something somewhere, but I can't find it. Any help would be appreciated. Thanks.

Posts: 204
Joined: 21 Mar 2013, 20:11

Re: TFTP Download Failed

Post by RaveMaker » 29 Jul 2013, 16:04

I don't see an issue with your configuration.
I would try to move the files to /tftpboot instead of /srv/tftp and change the settings to point to /tftpboot .

Posts: 2
Joined: 26 Jul 2013, 12:24

Re: TFTP Download Failed

Post by nixer » 21 Aug 2013, 17:56

I have tried all that I know and I can't get this to work, yet. I want to ask a question regarding dhcp configuration. I am wondering if my problem isn't somehow related to this issue: viewtopic.php?f=5&t=120.

I have a small network that uses a common linksys router which has been flashed with tomato firmware. My alteration to dnsmasq on the router contains only one line:
which is pointing to a grub entry and from this grub entry I can point to a pxe linux. This works fine. I can also enter "dhcp-boot=pxelinux.0,," and it will load the erpxe boot menu fine, but nothing will transfer by tftp.

In looking over the debian install instructions, at the bottom it mentions dhcp configuration which I have not done.
Add the following rules to your dhcp server:
filename "pxelinux.0";
Under Virtual Appliance it says:
ERPXE IP address is , To change it you should read Change IP article.
On the Change IP article it says:
In order to adjust ERPXE to the local IP Address of your server you first need to adjust your DHCP server settings:
Linux DHCPd:
next-server NEWIPADDRESS;
Do I need to amend anything in the "dhcp-boot" line in the tomato firmware? I do not know of anything else to ask. I have done everything else in the installation instructions. Thanks for any suggestions.

Posts: 204
Joined: 21 Mar 2013, 20:11

Re: TFTP Download Failed

Post by RaveMaker » 21 Aug 2013, 19:06

Your router config seems fine.
My guess is that the issue is with your TFTP configuration.
Try using TFTPD-HPA instead of ATFTPD and then try moving the files to /tftpboot instead of /srv/tftp/

TFTPD-HPA config:

Follow this tutorial and verify you haven't missed anything with PartedMagic plugin configuration:

Change the plugin IP address:
Several plugins use HTTP/NFS/SMB protocols to mount the rest of the OS after the first KERNEL,INITRD stage.
In order to mount the files from a correct location you will need to edit the .menu file included with the plugin.
Just look for the string within the .menu file and replace it with your IP address.

Posts: 1
Joined: 09 May 2016, 14:10

Re: TFTP Download Failed

Post by alfredalfred » 09 May 2016, 14:11

This works fine. I can also enter "dhcp-boot=pxelinux.0,," and it will load the erpxe boot menu fine, but nothing will transfer by tftp????

Post Reply