Problem Booting Slax

makthegr8
Posts: 17
Joined: 11 May 2012, 16:18

Problem Booting Slax

Postby makthegr8 » 26 May 2012, 11:18

Hi sir,

I have booted Hirenminixp successfully

Now I tried to boot slax, download plugin and configure it,

But Error occurred while booting that " Fatal Error Occured - can't find executable chroot command, somthing went wrong and we cant continue "

Pls help
RaveMaker
Posts: 204
Joined: 21 Mar 2013, 20:11

Re: Problem Booting Slax

Postby RaveMaker » 26 May 2012, 15:53

This error means you can't access the 'tftpboot/er/shares/slax/slax' folder.

Slax uses HTTP access to access the '/shares/slax/slax/' so just open a web browser and check this url:

"http://IPADDRESS-OF-TFTP-HTTP-Server/er/slax/"

Can you access this address?

If not then this is your issue probably a Web Server Config issue.

If you can access this url and you can see: /slax/,filelist.txt then there is probably a NIC driver issue with your client, try booting with VMware/VirtualBox in order to check it with a standard NIC.
makthegr8
Posts: 17
Joined: 11 May 2012, 16:18

Re: Problem Booting Slax

Postby makthegr8 » 28 May 2012, 09:54

Sir,

it is not able to browse

Did you mean it needs to create another virtual directory under er (Virtual directory created on iis ) which points to tftpboot\er\shares\slax\slax
RaveMaker
Posts: 204
Joined: 21 Mar 2013, 20:11

Re: Problem Booting Slax

Postby RaveMaker » 28 May 2012, 17:31

If you are using Apache as your web server then all you have to do is create a link:

Code: Select all

ln -s /tftpboot/er/shares /var/www/html/er

Assuming your root directory is '/var/www/html/' (CentOS default)
We have been using CentOS 5-6 with default 'httpd.conf' and it is working without issues.

If you are using IIS then it is just as simple,
just create a virtual directory called 'er' mapped to 'tftpboot/er/shares/'

Final result should be the same:
"http://IPADDRESS/er/slax/"

Now you should be able to see your shares list here:
"http://IPADDRESS/er/"
makthegr8
Posts: 17
Joined: 11 May 2012, 16:18

Re: Problem Booting Slax

Postby makthegr8 » 29 May 2012, 15:03

sir,

I did the same,

I am using IIS ( Windows XP SP3 ) & able to browse "http://192.168.0.1/er/slax/" on browser
but still same problem..

Pls help !!
RaveMaker
Posts: 204
Joined: 21 Mar 2013, 20:11

Re: Problem Booting Slax

Postby RaveMaker » 29 May 2012, 17:07

In your 192.168.0.1/er/slax/ you shold have another slax folder:
"192.168.0.1/er/slax/slax/"
And there you should have all the Slax files.

Also did you change the IP address in tftpboot/er/plugins/slax/slaxmain.menu?
makthegr8
Posts: 17
Joined: 11 May 2012, 16:18

Re: Problem Booting Slax

Postby makthegr8 » 30 May 2012, 14:45

Sir,

All the slax files are there in Slax folder

and also did the changes in slaxmain.menu file according my ip

but same problem
RaveMaker
Posts: 204
Joined: 21 Mar 2013, 20:11

Re: Problem Booting Slax

Postby RaveMaker » 30 May 2012, 16:46

Sounds like your environment is working correctly , perhaps there is an issue with you NIC.

First of all use filelist.txt supplied with slax plugin to verify the location of your Slax files.

Try booting from VirtualBox Using a standard NIC, if it won't work then there is an issue with your environment,
if it does work then Slax does not support you NIC by default.

I will setup ERPXE in our test environment using XP SP3 and IIS and verify the Slax plugin support.
Perhaps there are changes needed to be done (possible but not likely).

Return to “Troubleshooting and Problems”

Who is online

Users browsing this forum: No registered users and 1 guest

cron