Difficulties with XenServer/XenCenter usage

Posts: 3
Joined: 05 Apr 2014, 23:02

Difficulties with XenServer/XenCenter usage

Postby mtcj » 06 Apr 2014, 00:00


I'm trying to use ERPXE within a XenServer environment using XenCenter for administration, and I have been running into some unexpected difficulty. I was really impressed by this project when I ran across it at wikipedia.

To start with, I have a VM running a CentOS-based server with ERPXE installed and running in conjunction with our dhcp server. I can boot physical machines just fine off of the server. However, whenever I boot a VM, I am unable to see the menu. In addition, I don't believe the menu is receiving keyboard input - supposing it is just a viewing issue. The VM restarts as if I have not interrupted the menu timer (The VMs in question have nothing installed on their disk or have no disk).

I am at a loss to explain this behavior, since a PXE server I put together from scratch seems to work fine. It uses vesamenu.c32 and has a background image, as well as a screen-size change. Granted, mine is not as complex, and doesn't have any "INCLUDES"... As a result, I am not sure what the issue is. I would at least expect the first menu to load. Instead, when I boot from ERPXE, I get results like this:
failed boot ERPXE.png
Failed boot on XenCenter
failed boot ERPXE.png (26.89 KiB) Viewed 2945 times

I'm not sure if anyone else has used ERPXE with XenServer/XenCenter before, but I was hoping to get some suggestions as to what might be causing the issue. If I run across any solution on my own, I will try to post it here.

Posts: 3
Joined: 05 Apr 2014, 23:02

Re: Difficulties with XenServer/XenCenter usage

Postby mtcj » 06 Apr 2014, 01:44


I have found a fix. Somewhere between XenServer 6.2 and XenCenter and their vnc solution to view clients' screens, it appears there is a compatibility issue with PXELINUX 6.02

I had tried using all of the boot images (.0 files). When I copied in both the pxelinux.0 and vesamenu.c32 from my other server, which uses PXELINUX 4.04, I got immediate results.

Of course, there are a few items which are not working quite as I had hoped. I'm trying to see if that is due to my own tinkering while trying to get things to work, or due to the probable change in capability between PXELINUX 6.02 and 4.04. The main menu, for example, now receives a black background...

Also, I had to gunzip one of the files in the dsl plugin for it to start working... not sure if that is related or not.

Any thoughts appreciated!
Last edited by mtcj on 06 Apr 2014, 05:07, edited 1 time in total.
Posts: 3
Joined: 05 Apr 2014, 23:02

Re: Difficulties with XenServer/XenCenter usage

Postby mtcj » 06 Apr 2014, 04:55

I decided to try a few other versions of SYSLINUX, and I believe the 4.06 version is the latest one that seems to work:

This one seems to have fixed the black background issue on the main menu, but I am not sure if I will see more issues down the road. Is this version change likely to be an issue with anything else?
Posts: 204
Joined: 21 Mar 2013, 20:11

Re: Difficulties with XenServer/XenCenter usage

Postby RaveMaker » 08 Apr 2014, 14:02

ERPXE v1.2 is based on SYSLINUX 6.02 pre16.
SYSLINUX 6.02 - it is currently being tested for the next ERPXE release..

Also SYSLINUX 4.06 is a bit older but it seems to be stable so you can use that if it suits your needs.

The main difference is that version 6 support EFI boot.
This allows the EFI backend to hook into the generic TFTP, HTTP and FTP functionality.

You can read more here:

Return to “Troubleshooting and Problems”

Who is online

Users browsing this forum: No registered users and 2 guests