Bodhi Linux Live

commguy
Posts: 57
Joined: 20 Aug 2013, 06:38
Contact:

Bodhi Linux Live

Postby commguy » 13 Sep 2013, 19:29

I'm trying to set up Bohdi Live and I'm getting a strange error. When it gets to the part where it tries to boot casper it attemts to mount /tftpboot/er/shares/bodhi/ and repeatedly reports mount:protocol not supported

I'm not sure where to start with this one.
commguy
Posts: 57
Joined: 20 Aug 2013, 06:38
Contact:

Re: Bodhi Linux Live

Postby commguy » 13 Sep 2013, 19:54

Ok looked at syslog and I'm getting this on the server

Sep 13 10:53:06 PXEPI rpc.mountd[2047]: authenticated mount request from 10.0.0.134:803 for /tftpboot/er/shares/bodhi/i386 (/tftpboot/er/shares)
Sep 13 10:53:06 PXEPI rpc.mountd[2047]: refused unmount request from 10.0.0.134 for /cdrom (/): not exported

it's looking in the right place but it looks like the bodhi kernel is looking for something that isn't there.

still looking...

Edit: after a bit of digging my suspision is that it is a kernel issue with Bodhi. I've seen similar issues in Arch and the issue for them was the nfs module compiled with the newer kernel. for some reason it isn't talking to nfsv4. Can anyone verify this?
RaveMaker
Posts: 204
Joined: 21 Mar 2013, 20:11

Re: Bodhi Linux Live

Postby RaveMaker » 13 Sep 2013, 22:32

What version of Bodhi are you using?
commguy
Posts: 57
Joined: 20 Aug 2013, 06:38
Contact:

Re: Bodhi Linux Live

Postby commguy » 13 Sep 2013, 22:54

2.4.0, I just looked for 2.1.0 and I'm not finding any links for it. I managed to find the folder with the older builds but it only goes back to 2.2.0 in the 2x series.
RaveMaker
Posts: 204
Joined: 21 Mar 2013, 20:11

Re: Bodhi Linux Live

Postby RaveMaker » 14 Sep 2013, 03:03

Bodhi Version 2.4.0 works with CentOS 6 as NFS server.

Probably a Debian issue, try tweaking your NFS server to v3 only...
Maybe that would help.
commguy
Posts: 57
Joined: 20 Aug 2013, 06:38
Contact:

Re: Bodhi Linux Live

Postby commguy » 14 Sep 2013, 18:09

Unfortunatly I've decided to scrap bodhi for now. Without more drive space this plugin leaves me with less than 500mb. I need to upgrade some hardware on my pi first. I'll have to come back to this one later.

Return to “Troubleshooting and Problems”

Who is online

Users browsing this forum: No registered users and 1 guest